Incident History

Apr 29, 2026

1 month ago

Voice

Partial OutageAuto-detected
Voice

Resolved · April 30, 7:27 AM (in 9h 27m)

Status changed: partial outage → operational

Investigating · April 29, 10:00 PM

Status changed: operational → partial outage

Voice – seven.io Status