Dec 3, 2025
5 months ago
Minor outage of power supply
NoneInbound SMS
Resolved · December 3, 11:03 AM (in less than a minute)
Due to a power supply disruption, a portion of the hosted SIMs was unavailable for one hour.
Dec 3, 2025
5 months ago
Resolved · December 3, 11:03 AM (in less than a minute)
Due to a power supply disruption, a portion of the hosted SIMs was unavailable for one hour.