Incident History

Jul 17, 2026

3 days ago

Inbound SMS

Major OutageAuto-detected
Inbound SMS

Resolved · July 17, 10:56 AM GMT+2 (after 8 minutes)

Status changed: major outage → operational

Investigating · July 17, 10:47 AM GMT+2

Status changed: operational → major outage