Incident History

Jul 5, 2026

yesterday

Voice

Partial OutageAuto-detected
Voice

Resolved · July 5, 8:13 AM GMT+2 (in 1h 13m)

Status changed: partial outage → operational

Investigating · July 5, 6:59 AM GMT+2

Status changed: operational → partial outage