Incident History

May 10, 2026

2 months ago

Voice

Partial OutageAuto-detected
Voice

Resolved · May 10, 3:13 AM GMT+2 (after 16 minutes)

Status changed: partial outage → operational

Investigating · May 10, 2:57 AM GMT+2

Status changed: operational → partial outage