Incident History

Jun 18, 2026

8 hours ago

Inbound SMS

Major OutageAuto-detected
Inbound SMS

Resolved · June 18, 12:39 PM GMT+2 (in 50 minutes)

Status changed: partial outage → operational

Investigating · June 18, 12:12 PM GMT+2 (23 minutes earlier)

Status changed: major outage → partial outage

Investigating · June 18, 11:49 AM GMT+2

Status changed: operational → major outage