Incident History

Jun 28, 2026

yesterday

Inbound SMS

Major OutageAuto-detected
Inbound SMS

Resolved · June 28, 9:56 PM GMT+2 (in 9 minutes)

Status changed: major outage → operational

Investigating · June 28, 9:47 PM GMT+2

Status changed: operational → major outage