Jun 23, 2026
2 days ago
Inbound SMS
Major OutageAuto-detectedInbound SMS
Resolved · June 23, 1:00 PM GMT+2 (in 1h 13m)
Status changed: major outage → operational
Investigating · June 23, 11:47 AM GMT+2
Status changed: operational → major outage
Jun 23, 2026
2 days ago
Resolved · June 23, 1:00 PM GMT+2 (in 1h 13m)
Status changed: major outage → operational
Investigating · June 23, 11:47 AM GMT+2
Status changed: operational → major outage