Aug 20, 2026
yesterday
Voice
Partial OutageAuto-detectedVoice
Resolved · August 20, 3:36 PM GMT+2 (after 1h 12m)
Status changed: partial outage → operational
Investigating · August 20, 2:24 PM GMT+2
Status changed: operational → partial outage
Aug 20, 2026
yesterday
Resolved · August 20, 3:36 PM GMT+2 (after 1h 12m)
Status changed: partial outage → operational
Investigating · August 20, 2:24 PM GMT+2
Status changed: operational → partial outage