Incident History

Jul 20, 2026

20 hours ago

Inbound SMS

Major OutageAuto-detected
Inbound SMS

Resolved · July 20, 1:03 PM GMT+2 (after 21 minutes)

Status changed: major outage → operational

Investigating · July 20, 12:41 PM GMT+2

Status changed: operational → major outage