Incident History

Jul 14, 2026

7 days ago

Voice

Partial OutageAuto-detected
Voice

Resolved · July 14, 3:41 AM GMT+2 (after 26 minutes)

Status changed: partial outage → operational

Investigating · July 14, 3:14 AM GMT+2

Status changed: operational → partial outage