Incident History

Jul 20, 2026

18 hours ago

Inbound SMS

Major OutageAuto-detected
Inbound SMS

Resolved · July 20, 6:07 PM GMT+2 (after 3h 44m)

Status changed: major outage → operational

Investigating · July 20, 2:23 PM GMT+2

Status changed: operational → major outage