Incident History

Jun 27, 2026

3 days ago

Inbound SMS

Major OutageAuto-detected
Inbound SMS

Resolved · June 27, 3:19 AM GMT+2 (in 40 minutes)

Status changed: major outage → operational

Investigating · June 27, 2:39 AM GMT+2

Status changed: operational → major outage