Incident History

Jul 6, 2026

17 hours ago

Voice

Partial OutageAuto-detected
Voice

Resolved · July 6, 2:43 AM GMT+2 (in 37 minutes)

Status changed: partial outage → operational

Investigating · July 6, 2:06 AM GMT+2

Status changed: operational → partial outage