Aug 18, 2026
13 hours ago
Voice
Partial OutageAuto-detectedVoice
Resolved · August 18, 4:27 PM GMT+2 (after 3h 1m)
Status changed: partial outage → operational
Investigating · August 18, 1:26 PM GMT+2
Status changed: operational → partial outage
Aug 18, 2026
13 hours ago
Resolved · August 18, 4:27 PM GMT+2 (after 3h 1m)
Status changed: partial outage → operational
Investigating · August 18, 1:26 PM GMT+2
Status changed: operational → partial outage