Incident History

May 2, 2026

29 days ago

Voice

Partial OutageAuto-detected
Voice

Resolved · May 2, 3:14 AM (in 1h 57m)

Status changed: partial outage → operational

Investigating · May 2, 1:17 AM

Status changed: operational → partial outage