Reachability by phone
Incident Report for seven.io
Resolved
Our phone is back and we are reachalbe again for you. Thanks for your patience and your understanding.
Posted Mar 17, 2022 - 14:56 CET
Identified
The problem is identified and we are waiting for a solution from our telephony partner.
Posted Mar 17, 2022 - 11:35 CET
Investigating
Dear customers, due to a breakdown of our telephone system, we are temporarily unavailable by phone. Please contact us alternatively via mail or live chat.
Posted Mar 17, 2022 - 09:46 CET