Temporary outage on one production server

Incident Report for seven.io

Postmortem

An unexpected failure of network interfaces occurred on our main server, resulting in extended outages. We have now restored operations. There are still performance issues in some areas, which we are working on resolving. Such repeated outages are very stressful for us. Therefore, we are now massively expanding our infrastructure and converting it to a highly available cluster environment. We will keep you regularly updated on the progress of this upgrade so that you are always aware of the measures we are taking to prevent similar problems in the future.

We regret to announce that there were repeated disruptions to the main server between October 13th and 15th:

October 13th, 2025, 9:01 PM – Main server down, incident listed on the status page, duration: approximately 8 hours.
October 14th, 2025, 6:54 PM – Disruption of individual services, no incident update listed on the status page, duration: approximately 1 hour.
October 15th, 2025, 11:35 PM – Disruption of individual services, no incident listed on the status page, duration: approximately 15 minutes.
October 16th, 2025 - Minor performance losses, no downtime recorded.

We apologize for any inconvenience and thank you for your understanding.

Posted Oct 16, 2025 - 12:00 CEST

Resolved

Between October 13, 2025, 21:06 UTC+2 and October 14, 2025, 05:11 UTC+2, one production node became unresponsive due to an unexpected system failure.
The node was restored to normal operation, and all services have been stable since.
Further investigation is underway to identify the underlying cause.
Posted Oct 13, 2025 - 21:00 CEST